Pete Freitag Pete Freitag

Acme Client Error Valid not acceptable for finalization

web

I have a few static sites that are hosted using Netlify. I received an email from Netlify about one of my sites, a Content-Security-Policy Header Reference that said:

Failed to renew TLS certificate for content-security-policy.com. The TLS certificate for content-security-policy.com will expire on Apr 23, 2020. We tried to renew it, but got this error message:

Acme::Client::Error: Order's status ("valid") is not acceptable for finalization

Netlify uses Let's Encrypt to automatically generate the TLS certificate using the ACME protocol and domain validation. While I've worked quite a bit with Lets Encrypt I've never received that error. It could have been due to a bug in Netlify's Acme client implementation.

It worked itself out

In the end the certificate was actually issued properly, so if you get that message from Netlify be patient, it should hopefully work itself out within 24 hours.


Like this? Follow me ↯


Acme Client Error Valid not acceptable for finalization was first published on April 08, 2020.


Post a Comment